忍者ブログ
NWとかLinuxなんかに関する技術的なものを記載してます。。。てかぶっちゃけ。備忘録ですw 一部Solarisとかも書いたりするかもしれませんw 最近は仮想化やストレージなんかにも興味あって手出したりしてますw
カレンダー
08 2017/09 10
S M T W T F S
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
バーコード
ブログ内検索
<AD>
 
amazon
ムームードメイン
アクセス解析
2017/09/27 (Wed)
×

[PR]上記の広告は3ヶ月以上新規記事投稿のないブログに表示されています。新しい記事を書く事で広告が消えます。

2009/11/23 (Mon)

とりあえずベースとなるXenServerをインストールしていきます。

ちなみにXenServerホストOSとなるハードウェアの要件は以下のとおり。

1.XenServerホスト
サーバーシステム 64-bit x86 サーバーシステム
CPU 2 GHz以上(1.5 GHz最低)、マルチコアを推奨
* Windowsゲストの稼動には、Intel VTまたはAMD-Vが必須
* リソースプールの利用には、同じCPUファミリ・ステッピングでレベルあること
物理メモリ 1GB - 128GB
NIC 100Mbps以上
ハードディスク ローカルまたはファイバチャネルで接続された、60GB以上のディスク領域(16GB最小)

 

※詳細な必要要件はCitrixのサイトを確認してください。

 

何はともあれとりあえずXenServerをダウンロードします。

ダウンロードサイトはCitrixのサイトからダウンロードします。

ダウンロードにあたってユーザの登録が必要です。

 

ユーザ登録後に以下のページの 『Download Installer』をクリックして

ダウンロードし、ISOイメージをCD-Rなんかに焼きます。 
xendownload_2.jpg










XenServer
をインストールする端末に焼いたCD-Rをセットし起動します。

起動すると以下の画像のような画面になります。

以下の画面で「Enterキー」を押してインストールを開始します。 
xenserver01.jpg








あとは環境に合わせてGUIで設定していきます。

詳細なインストール手順についてはCitrixのサイトにありますので

そちらを参照してください。
XenServerインストール手順

 手順どおりインストール完了したら次はXenCenterのインストールです。

XenCenterのインストールは次回です。 

point1_1b.gif推奨のマルチコアCPUの一覧はこちら


2009/10/12 (Mon)

それでは早速Ciscoルータを設定してみます。

1. グローバル設定モードで設定を始めます。
Router>en
Router# conf t

2. まずはタイムゾーンを設定します。
Router(config)# clock timezone JST 9

3. Crlt + zでグローバル設定モードを抜けて特権モードで時間合わせ。
Router# clock set 19:30:00 12 Oct 2009

4. 再びグローバル設定モードになります。
Router# conf t
Router(config)#

ホスト名を設定します。
Router(config)# hostname R01

するとプロンプトが↓のように変わります。
R01(config)#

5. 次にLAN側のインターフェースを設定します。
Cisco851のLANポートFE0 ~ FE3の設定となります。
また、FE0 ~ FE3のポートにVLAN1以外のVLANは設定できません。

R01(config)#interface vlan 1
R01(config-if)#ip address 192.168.120.1 255.255.255.0
R01(config-if)#exit

6. 次にWAN側のインターフェースを設定します。
WAN側の設定はPPPoEを使いますのでインターフェースはDialerになります。
interface Dialer 1
R01(config-if)# mtu 1438                                        -> こいつは必ず設定しましょう。(フレッツプレミアムはこの値より大きいと接続できない。)
R01(config-if)# encapsulation ppp                        -> カプセル化の指定をPPPに設定
R01(config-if)# dialer pool 1                                    -> dialer pool 1 を定義
R01(config-if)# ppp authentication chap callin    -> pppの認証方法
R01(config-if)# ppp chap hostname aaaaa         ->(プロバイダの接続ホスト名)
R01(config-if)# ppp chap password 7 xxxxxxxxx   ->(プロバイダの接続パスワード)
R01(config-if)# exit

7. 上記で設定したDialer 1を物理インターフェースに適用します。
物理インターフェースはFE4になります。
R01(config)# interface fastEthernet 4
R01(config-if)#pppoe enable group global            -> pppoeを有効にします。
R01(config-if)#pppoe-client dial-pool-number 1   -> Dialer 1で定義した プール番号を指定

8. 次にdialer-list/アクセスリストを設定し、ダイヤルを発信する発信者/パケットを定義します。
以下の場合はではすべての IP パケットを設定。
R01(config-if)# access-list 1 permit any                  -> これがないとアクセスできない。
R01(config-if)# dialer-list 1 protocol ip permit

9. 定義したdialer-listを適用します。
適用するインターフェースはDialer 1になります。
R01(config)# interface dialer 1
R01(config-if)# dialer-group 1
R01(config-if)# exit

10. NAT変換用のアクセスリストを作成します。
R01(config)# ip nat inside source list 1 interface Dialer1 overload

11. NAT変換用のアクセスリストを適用します。
VLAN側
R01(config)#interface vlan 1
R01(config-if)# ip nat inside
R01(config)#exit

Dialer1側
R01(config)#interface dialer 1
R01(config-if)#ip nat outside
R01(config-if)#exit

12. ルーティングを設定します。
R01(config)#ip route 0.0.0.0 0.0.0.0 Dialer1

てな感じです。
これで無事接続できると思います。

サンプルのコンフィグをに書いてみました。
ご参考までに。。。

!--//sample
hostname R01
!
no aaa new-model
!
resource policy
!
clock timezone JST 9
ip subnet-zero
!
ip cef
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 description ***WAN Interface***
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Vlan1
 ip address 192.168.120.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1393
!
interface Dialer1
 mtu 1438
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname user@user
 ppp chap password 7 password
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
!---//sample


今回使用したCiscoルータはこちら↓
 CISCO Cisco 851小規模オフィス向けセキュアブロードバンドルータ 無線LAN対応 CISCO851W-G-J-K9

2009/10/12 (Mon)
前回CUTの設定が完了したんで次からはCiscoルータの設定に入ります。。。

でもその前にちょっとだけCiscoルータの基本を少し。

まず電源を入れて起動させると設定が何も入っていなければ、 ↓のようになります。
 Would you like to enter the initial configuration dialog? [yes/no]:
 
ここでnを入力し、[Enterキー]をおします。
すると…↓のようになります。

Roter>
 
上はユーザモードと呼ばれるモードです。

ユーザモード
ユーザモードは主にルータのステータスを表示することができます。
しかし、確認できる内容には、制限があり、ルータの全てのステータスを確認することはできません。
 
ユーザモードのままでは設定はできないのでまず、特権モードになります。
 
特権モードになるには以下のコマンドを入力します。
Router> enable

すると下のようにプロンプトが変わったと思います。

Router#

これが特権モードです。

特権モード

特権モードはルータのステータスを確認することができます。
ユーザモードと違って制限は、ありません。
また、ファイルをコピーしたり、ネットワーク診断用のコマンドが、実行できます。
主に使うコマンドは、以下のコマンドになると思います。
このモードから下の階層は、管理者がアクセスするモードになります。
・show
・copy
・telnet
・ping
・traceroute

次にグローバル設定モードになります。

コマンドは以下です。
Router# configure terminal

するとプロンプトが下のようになったと思います。

Router(config)#

グローバル設定モード
ルータ全体に関わる設定を行います。
ホスト名、パスワードなどを主に設定します。

その他にインタフェースの詳細設定を行う「インターフェース設定モード」や、
ルーティングの詳細設定を行う「ルータ設定モード」、ラインの設定を行う「ライン設定モード」があり、
それらの設定モードはすべてグローバル設定モードから遷移します。
 
Ciscoルータの入門書としてつかえる一冊↓
現場で使えるCiscoルータ管理者リファレンス130の技 (Network engineer)




参考:@network Cisco・アライド実機で学ぶ
2009/10/12 (Mon)
タイトルに「NW」とあるのにまったくといっていいほどネットワークネタがないので
今回はネットワークネタをやってみようと思います。

家で使っている回線がNTTフレッツプレミアムを使っており、
このまんまではPPPoEがつかえません。

ちなみにうちで使っているプロバイダはBiglobeなんか使ってたりします。
やはりそれなりの大手プロバイダの方が何かと便利かなぁって思いまして…。

話を戻して…IP-Sec なんかも無理なんでPPPoEを使えるように設定します。
設定はこんな感じ。。。

CTUにログインします。

CTU
にログイン後に左側のメニューの[詳細設定]をクリック。

詳細設定画面の下のほうにPPPoEの設定をします。
pppoe.jpg


編集をクリックし、PPPoEをするに変更し、セッション数を設定します。
あとは設定反映すればCTU側の設定は完了です。

ほら簡単w
で次はルータを設定します。。。

ルータの設定は次回にしましょうw


Biglobeの9大特典はこちらから↓
2009/10/11 (Sun)
プロトコルを分析するためのソフトウェアであるwiresharkのerf ファイルに
脆弱性が存在します。

■影響を受けるシステム
  • Wireshark 1.2.2 より前のバージョン

 

なお、同梱されている Tshark も本脆弱性の影響を受けます。


■対策
アップデートする
開発者が提供する情報をもとに最新版へアップデートしてください。

ワークアラウンドを実施する
対策版を適用するまでの間、以下の回避策を適用することで、本脆弱性の影響を軽減することが可能です。

  • 制限されているアカウントで Wireshark を利用する
wireshark1.2.2より以前のバージョンを使ってる人はアップデートしましょう。

ベンダ リンク
Wireshark Wireshark 1.2.2 Release Notes
  Revision 29364 - View of /trunk/wiretap/erf.c
  Get Wireshark
  Wireshark Security




NWとかLinuxとか
Blog Produce : iwa / Template design : Fomalhaut
[PR]忍者ブログ / [PR]
転職 債務整理 ロト6 眼科 歯科 歯科医 特定調停 葬儀 SEO 岩盤浴 英会話 投資信託 金融 FX 住宅ローン UFJ 資産運用 消費者金融 融資 ビジネスローン
税理士 外国為替 マンション 賃貸マンション 中古車 学生マンション